1

I'm running a few collators for a parachain connected to polkadot, but after they've been running for sometime we stop being able to connect using rpc, we are using polkadot v1.3.0, does anyone know what could be the issue? I thought it could be related to the hardware specs of the nodes they are running on, but I've upgraded the instances they are running on to c6id.2xlarge and the issue persists. The collators keep producing blocks without any issues.

Update:

I can not see any errors in the collator logs, the error I get from the polkadotjs app is 1006:: Abnormal Closure

The command used to start the collator is: ./target/release/parachain --collator --base-path /tmp/chain-170223/collator-data/ --port 40333 --rpc-port 9946 --rpc-external --rpc-cors all --chain ./chain-spec-raw-170223.json -- --execution wasm --base-path /tmp/chain-170223/relay-data/ --chain ./resources/polkadot.json --port 30333 --rpc-port 9944 --rpc-external --rpc-cors all --wasm-execution Compiled --pruning 1000

Thanks.

4
  • Any error message or just not receiving response?
    – Alex Bean
    Commented Dec 27, 2023 at 8:16
  • I've updated the post describing the error message
    – Sebastian
    Commented Dec 27, 2023 at 22:27
  • What's your boot command?
    – AurevoirXavier
    Commented Dec 28, 2023 at 18:30
  • I've updated the post with the command
    – Sebastian
    Commented Dec 28, 2023 at 21:43

2 Answers 2

0

If you see this error using PolkadotJS UI in the browser can be because something is blocking the connection for example uBlock. See this issue: FATAL: Unable to initialize the API: disconnected from wss://pub.elara.patract.io/kusama: 1006:: Abnormal Closure #3960

You can try the curl command in your terminal to see if you have the same error:

curl -H "Content-Type: application/json" -d '{"id":1, "jsonrpc":"2.0", "method": "rpc_methods"}' your-rpc-endpoint

Other checks you can do in the browser are the follow Polkadot-JS UI: How to Troubleshoot Connection Issues

1
  • Thanks! But why would it be that I'm able to connect at first? it is only after the collator has been running for some time that I have the issue.
    – Sebastian
    Commented Jan 1 at 20:34
0

The issue seems to be solved now, the fix was to increase the amount of rpc connections allowed by the node, using the --rpc-max-connections flag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.