I'm trying to update my node from SDK version 1.2.0 to 1.3.0. To do so I make this change to each package in my Cargo.toml:

- sp-core = { tag = "polkadot-v1.2.0", git = "https://github.com/paritytech/polkadot-sdk" }
+ sp-core = { tag = "polkadot-v1.3.0", git = "https://github.com/paritytech/polkadot-sdk" }

Here is the full commit

For some reason a crate somewhere in the dependency graph called vandersnatch_vrfs is not compiling. Any idea what I might need to do?

error[E0616]: field `keyset_part_size` of struct `ring::PiopParams` is private
  --> /home/joshy/.cargo/git/checkouts/ring-vrf-fa8519651343a7ee/4b09416/bandersnatch_vrfs/src/ring.rs:70:26
70 |         self.piop_params.keyset_part_size
   |                          ^^^^^^^^^^^^^^^^ private field

For more information about this error, try `rustc --explain E0616`.
error: could not compile `bandersnatch_vrfs` (lib) due to previous error
  • DQ: Have you tried to set it to branch = "release-polkadot-v1.3.0"? Commented Nov 16, 2023 at 22:09
  • @ArturGontijo branch = "release-polkadot-v1.3.0" fixes it. Can you please post that as an answer so I can accept it? I've updated my question to explicitly state what I had tried. In your answer, please include the semantics of the release branches vs tags if you know it. Commented Nov 17, 2023 at 21:37
  • Could you elaborate on that? I changed to branch = "release-polkadot-v1.3.0" on my own code base but I'm still getting the exact same compilation error. Commented Nov 18, 2023 at 5:54
  • @KazunobuNdong that's odd =/. Maybe you should run a cargo clean and rebuild everything from the ground. Commented Nov 18, 2023 at 12:41

1 Answer 1


Have you tried to set it to branch = "release-polkadot-v1.3.0"?

I can see that the tag = "polkadot-v1.3.0" is not pointing to the same commit as that branch is, so maybe we need to update that tag. Not sure who would be able to do that but I'll communicate that in the Element's channel.

(I recommended that branch as I'm using it on some projects and it is working fine)

  • Indeed, switching to that branch and running cargo update worked for me. Thank you. Regarding updating the tag, I think git tags are supposed to never change once published. git tag docs. Commented Nov 20, 2023 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.