0

When following ink getting started tutorial at https://use.ink/getting-started/running-substrate I am stuck at one of the steps.

After starting contracts node in dev mode with the following command:

substrate-contracts-node --dev

I am trying to connect to UI via https://contracts-ui.substrate.io/ choosing local node. Getting

Could not connect to ws://127.0.0.1:9944
Make sure you are running a local substrate-contracts-node.
substrate-contracts-node --dev

I tried switching off ufw but it didn't help.

I found similar question here but there problem was missing --dev switch, which is not the case here, I pass --dev explicitly.

This is the output of my node console

2023-11-13 09:46:10.415  INFO main sc_cli::runner: Substrate Contracts Node    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: ✌️  version 0.33.0-unknown    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: ❤️  by Parity Technologies <[email protected]>, 2021-2023    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: 📋 Chain specification: Development    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: 🏷  Node name: cool-jellyfish-4492    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: 👤 Role: AUTHORITY    
2023-11-13 09:46:10.416  INFO main sc_cli::runner: 💾 Database: ParityDb at /tmp/substrateeTNwIZ/chains/dev/paritydb/full    
2023-11-13 09:46:11.566  WARN main sub-libp2p: Can't listen on /ip6/::/tcp/30333 because: Other(Custom { kind: Other, error: Custom { kind: Other, error: Other(Left(Left(Left(Left(Right(Transport(Os { code: 97, kind: Uncategorized, message: "Address family not supported by protocol" }))))))) } })    
2023-11-13 09:46:12.660  INFO main sc_rpc_server: Running JSON-RPC server: addr=127.0.0.1:9944, allowed origins=["*"]    

How the debug why it is not running as it should?

2
  • Which browser are you using? I think some of them blocks access to not secure websockets ws://. You should allow that in the browser's config. Nov 16, 2023 at 14:18
  • I am using Brave, tried on Firefox now and it does work! Please post your comment as an answer so I can accept it.
    – jangorecki
    Nov 16, 2023 at 15:32

1 Answer 1

1
+50

Some browsers do not allow access/connection to not secure websocket (ws://) so you need to allow that by changing your browser's configs.

(OP and I use firefox and it works without changes)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.