2

I recently upgraded the chain from version 0.9.36 to 1.0.0. Following this update, when attempting to perform a runtime upgrade on the blockchain, I encountered an error that resulted in the chain no longer producing blocks. The error message is as follows:

2023-09-27 09:37:13 Proposing failed: Import failed: Error at calling runtime api: Failed to get runtime version: runtime requires function imports which are not present on the host: 'env:ext_statement_store_submit_statement_version_1 

enter image description here

3
  • 1
    Your runtime upgraded caused a migration which took longer than allowed, there are some various ways of unbricking your block chain. Nodle parachain was stuck for several weeks until governance on polkadot allowed for a force upgrade
    – Simson
    Sep 27, 2023 at 5:20
  • you can refer to comments in this question substrate.stackexchange.com/questions/9677/… Sep 27, 2023 at 5:25
  • can you please explore which comment you are pointing to related migration, contract pallet or anyone else?
    – Pankaj
    Sep 27, 2023 at 6:01

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.